BMW
X1 / X2
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW X1 (F48) and X2 (F39) Forums General BMW X1 Forum (F48) Transmission Error

Post Reply
 
Thread Tools Search this Thread
      10-17-2020, 05:04 AM   #155
CYclonic
Registered
0
Rep
3
Posts

Drives: BMW X1
Join Date: Oct 2020
Location: Australia

iTrader: (0)

Quote:
Originally Posted by Bmwforlife? View Post
I used your guide and it worked! Minor difference in my car were 3 cables going to the arm rest for a cell phone docking accessory. It was a lot of work to get to that little spring. I wish I could just buy a new spring rather than adjust the broken one. I hope it doesn’t break again. It took me a long time to do everything, but it will be much faster if I have to go back in again. What a pain for a tiny little spring!

An improvement to your guide would be with your step 10 on removing the gear selector unit. All you gotta do is turn the unit over and align the gear to line up the semi-round clip to the hole at the bottom. Once aligned you need to push the semi-round clip through from the bottom using a small screwdriver like the jeweler’s flathead. I hope that helps others attempting this.

Another minor improvement would be to move the passenger seat prior to disengaging the battery for the second item of step 4.

Thanks again, James!

Hi bro,

My car is the same as yours as there are three sensors at the back vent that need to be disconnected. However two of them can hardly be removed. Can you give me a hint on how to disconnect them?
And also, do we need to remove the vent tube as well? The guide doesn't mention so I didn't do. But it covers the selection gear so the gear cannot be lift up.

Thanks with regards
Attached Images
  
Appreciate 0
      10-17-2020, 07:44 AM   #156
mDrive2
Registered
0
Rep
4
Posts

Drives: x1
Join Date: Oct 2020
Location: Canada

iTrader: (0)

Use a small flat screwdriver to disconnect those two connectors. The big one is easy to disconnect if you rotate the top stopper.
And yes, the plastic vents need to be removed.

Quote:
Originally Posted by CYclonic View Post
Hi bro,

My car is the same as yours as there are three sensors at the back vent that need to be disconnected. However two of them can hardly be removed. Can you give me a hint on how to disconnect them?
And also, do we need to remove the vent tube as well? The guide doesn't mention so I didn't do. But it covers the selection gear so the gear cannot be lift up.

Thanks with regards
Attached Images
 
Appreciate 0
      11-06-2020, 12:44 PM   #157
PatrickT
Registered
0
Rep
1
Posts

Drives: F20
Join Date: Aug 2017
Location: Netherlands

iTrader: (0)

@jamessfarnell

Thank you very much for your DIY. It helped me alot. Just completed this fix to my MINI F56 '15.

Cheers! Patrick (Netherlands).
Appreciate 0
      11-18-2020, 03:31 PM   #158
Vagabonder77
Registered
0
Rep
1
Posts

Drives: 2016 BWW X1
Join Date: Nov 2020
Location: Dallas, TX, USA

iTrader: (0)

Another vehicle with same issue

Just in case anyone ever files a lawsuit for this, my 2016 BMW X1 has the exact same problem. BMW Customer Relations refused to offer any assistance. The vehicle has only 53,000 miles on it. The local dealership in Texas wants to charge $2,267.19 for a replacement. I even have an extended warranty, but of course, it doesn't cover this part. Last 7 of VIN: 5F65762.
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:18 PM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST