BMW
X1 / X2
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW X1 (F48) and X2 (F39) Forums General BMW X2 Forum (F39) Carplay display changed recently...

Post Reply
 
Thread Tools Search this Thread
      01-17-2020, 02:57 PM   #1
satz
Captain
Australia
86
Rep
986
Posts

Drives: 2019 BMW X3 M40i
Join Date: Dec 2014
Location: Canberra

iTrader: (0)

Carplay display changed recently...

I noticed the carplay display screen (and some of its operation), seemed to have changed recently. I haven't sent the car in for service for a long time (so it can't be any software update in the car).

Could an IOS update on the Iphone itself cause the carplay screen to be different?
__________________
2019 X3 M40i (Sophisto grey).
Previous: 2019 BMW X2 Msport, petrol FWD, 7 spd DCT, Mineral Grey, Black Dakota leather, Adaptive Suspension, Harman/Kardon
Previous: 2009 335i E90 LCI
Appreciate 0
      01-17-2020, 03:08 PM   #2
billnchristy
Lieutenant
188
Rep
504
Posts

Drives: 2019 X2 m35i
Join Date: Feb 2019
Location: Atlanta

iTrader: (0)

Garage List
I haven’t seen a change
Appreciate 0
      01-17-2020, 06:57 PM   #3
kavatski
Private First Class
Canada
31
Rep
104
Posts

Drives: 2019 X1 28iX
Join Date: Jul 2019
Location: Nova Scotia

iTrader: (0)

Did you update your phone recently? iOS 13 included a major update to CarPlay.
Appreciate 0
      01-17-2020, 07:31 PM   #4
billnchristy
Lieutenant
188
Rep
504
Posts

Drives: 2019 X2 m35i
Join Date: Feb 2019
Location: Atlanta

iTrader: (0)

Garage List
I’ve had 13 for some time, maybe I just missed it
Appreciate 0
      01-18-2020, 08:15 AM   #5
dianebrat
Second Lieutenant
United_States
37
Rep
216
Posts

Drives: 2019 orange x2 xDrive28i
Join Date: Dec 2018
Location: Boston'ish

iTrader: (0)

Quote:
Originally Posted by satz View Post
Could an IOS update on the Iphone itself cause the carplay screen to be different?
Most definitely.
Look online and see if you can show us one of the different screens, the "summary" screen is new with iOS 13
Appreciate 0
      01-18-2020, 09:06 AM   #6
CajunBMW
Lieutenant
United_States
184
Rep
409
Posts

Drives: BMW 340i, Chrysler Van
Join Date: Mar 2019
Location: Shreveport, LA

iTrader: (0)

Yes the screen changed when ios13 was added. It took some getting used to since the layout changed, but I am now fine with it. For me I think the functionality changed for the better. The only thing I note that I have not solved and maybe I can change this on a setting, but texts come in and disappear quickly. I know they are in the text section, but they used to stay up for a good amount of time on the main screen. Thus at my convenience I could hit idrive without even looking and Siri would read the text to me. I have to play with this more, but other than that I am fine with exchanges.
Appreciate 0
      01-18-2020, 04:19 PM   #7
satz
Captain
Australia
86
Rep
986
Posts

Drives: 2019 BMW X3 M40i
Join Date: Dec 2014
Location: Canberra

iTrader: (0)

Mine now seems to sometimes default to the ugly 'Playing Now' screen rather than the normal BMW display. Any way to opt out of that happening?
__________________
2019 X3 M40i (Sophisto grey).
Previous: 2019 BMW X2 Msport, petrol FWD, 7 spd DCT, Mineral Grey, Black Dakota leather, Adaptive Suspension, Harman/Kardon
Previous: 2009 335i E90 LCI

Last edited by satz; 01-18-2020 at 06:52 PM..
Appreciate 0
      01-18-2020, 06:52 PM   #8
satz
Captain
Australia
86
Rep
986
Posts

Drives: 2019 BMW X3 M40i
Join Date: Dec 2014
Location: Canberra

iTrader: (0)

I updated my IOS to 13.3 some days ago and that's what's caused these changes on Carplay.

Another issue I have now is that the phone takes ages to connect, and sometimes just does not connect and I have to do it manually...
__________________
2019 X3 M40i (Sophisto grey).
Previous: 2019 BMW X2 Msport, petrol FWD, 7 spd DCT, Mineral Grey, Black Dakota leather, Adaptive Suspension, Harman/Kardon
Previous: 2009 335i E90 LCI
Appreciate 0
      01-21-2020, 02:41 AM   #9
Patrick852
Private First Class
Hong Kong
55
Rep
149
Posts

Drives: 15 320iED, 18 X2 sDrive20i MSX
Join Date: Mar 2017
Location: Hong Kong

iTrader: (0)

Quote:
Originally Posted by satz View Post
I updated my IOS to 13.3 some days ago and that's what's caused these changes on Carplay.

Another issue I have now is that the phone takes ages to connect, and sometimes just does not connect and I have to do it manually...
The same happened to me. Moreover, it connected the wifi in my house and does not disconnect when I get in the car, then the CarPlay wifi is not able to connect automatically. Even I drove away for a mile or so, no automatic connection ever made, have to do it manually.
Appreciate 0
      01-21-2020, 02:51 PM   #10
satz
Captain
Australia
86
Rep
986
Posts

Drives: 2019 BMW X3 M40i
Join Date: Dec 2014
Location: Canberra

iTrader: (0)

sounds like this time it's due to IOS rather than BMW...
__________________
2019 X3 M40i (Sophisto grey).
Previous: 2019 BMW X2 Msport, petrol FWD, 7 spd DCT, Mineral Grey, Black Dakota leather, Adaptive Suspension, Harman/Kardon
Previous: 2009 335i E90 LCI
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 05:11 PM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST