BMW
X1 / X2
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW X1 (F48) and X2 (F39) Forums General BMW X1 Forum (F48) Bimmercode Adventure

Post Reply
 
Thread Tools Search this Thread
      04-27-2019, 12:46 PM   #177
Viltronian
New Member
2
Rep
9
Posts

Drives: BMW X1 28i
Join Date: Jan 2019
Location: Isla Sorna

iTrader: (0)

Quote:
Originally Posted by MJE60 View Post
Possibly to do with different gearboxes. Correct me if I am wrong but petrol F48 have DSG boxes whereas xDrive and diesels have Aisin auto boxes.
Yup, its definitely not Aisin. My papers list 7 speed steptronic. November 2018. Too bad! Oh well, I'll just wait for my next car to try it.
Appreciate 0
      04-29-2019, 04:23 PM   #178
xlr8it
Private
xlr8it's Avatar
Australia
27
Rep
67
Posts

Drives: F48 X1 20d, SLK55AMG
Join Date: Nov 2011
Location: Sydney Australia

iTrader: (0)

Just tried it in mine, works like it should with the little flag coming on in the dash, the car is a 2016 20D Xdrive
Appreciate 1
      04-30-2019, 04:35 AM   #179
Viltronian
New Member
2
Rep
9
Posts

Drives: BMW X1 28i
Join Date: Jan 2019
Location: Isla Sorna

iTrader: (0)

Quote:
Originally Posted by xlr8it View Post
Just tried it in mine, works like it should with the little flag coming on in the dash, the car is a 2016 20D Xdrive
*

Last edited by Viltronian; 09-08-2019 at 01:02 PM.. Reason: *
Appreciate 0
      05-07-2019, 07:44 AM   #180
Takabo
Private
Takabo's Avatar
Japan
27
Rep
53
Posts

Drives: 2019 F39 X2
Join Date: Mar 2019
Location: Osaka, Japan

iTrader: (0)

Hello everyone.

The F20 iDrive (ID4) was able to display the GPS trajectories.

However, the F39(F48) iDrive (ID6, Professional) can not display GPS trajectories.

Do you know the setting for displaying the GPS trajectories of ID6? Thank you.

Last edited by Takabo; 05-08-2019 at 06:54 AM..
Appreciate 0
      05-17-2019, 03:55 PM   #181
StefanJ
Private First Class
StefanJ's Avatar
21
Rep
112
Posts

Drives: BMW X1 F48 sDrive 18d
Join Date: Mar 2019
Location: Romania

iTrader: (0)

Hello everyone!

I want to share with you a small coding that I discovered. For me it is useful.
The coding is for "Bord computer autoreset time interval".
On my car (F48 sDrive 18d 2016), this default time interval was 4 hours and there was no option to change it.

So, here it is:
Instrument Cluster ->>
change to Expert mode ->>
3000 Anzeige_Konfiguration ->>
search for BC_AUTORESET_ZEIT ->>
press CUSTOM VALUE ->>
enter the time interval you wish, like this: 02 = 2 h; 08 = 8 h; or whatever you want.

Then choose this new added option and CODE .

The new time interval will be used from now on.
Appreciate 0
      05-26-2019, 10:54 PM   #182
StefanJ
Private First Class
StefanJ's Avatar
21
Rep
112
Posts

Drives: BMW X1 F48 sDrive 18d
Join Date: Mar 2019
Location: Romania

iTrader: (0)

Hello!

I own an X1 sDrive 2016, manufactured for European market. The car came with only one central locking button, on the driver door (left) and with a blanking plate in the similar position on the right door.
I installed a central locking button on the right door, but it is not working. The only thing that it is working on the button is the illumination light. The car has already the necessary wiring, factory installed.
Maybe it is a coding that can be made/ modified, in order to make functional both door buttons.
Does anyone know?

Regards!
Appreciate 0
      05-27-2019, 02:36 AM   #183
Neworgri
Enlisted Member
Neworgri's Avatar
No_Country
26
Rep
39
Posts

Drives: BMW X1 s18i 2019
Join Date: May 2019
Location: *

iTrader: (0)

Fog lights with welcome lights would be nice. Does anyone knows how to do it on the X1?

Edit: P.S: If anyone wants code their rear lights and their blinkers, go here > https://f48.bimmerpost.com/forums/sh....php?t=1618231

Last edited by Neworgri; 05-27-2019 at 12:00 PM..
Appreciate 1
      05-27-2019, 12:18 PM   #184
ejw2011
Second Lieutenant
ejw2011's Avatar
53
Rep
225
Posts

Drives: x3 F25 35i, x1 F48 28i
Join Date: Aug 2011
Location: East coast

iTrader: (1)

[QUOTE=Neworgri;24836092]Fog lights with welcome lights would be nice. Does anyone knows how to do it on the X1?

Edit: P.S: If anyone wants code their rear lights and their blinkers, go here > https://f48.bimmerpost.com/forums/sh....php?t=1618231[/QUOTE

If you have bimmercode app under FEM there is an option to select fog lights to enable with welcome lights.
Appreciate 0
      05-27-2019, 02:16 PM   #185
Neworgri
Enlisted Member
Neworgri's Avatar
No_Country
26
Rep
39
Posts

Drives: BMW X1 s18i 2019
Join Date: May 2019
Location: *

iTrader: (0)

Quote:
Originally Posted by ejw2011 View Post

If you have bimmercode app under FEM there is an option to select fog lights to enable with welcome lights.
Its not there. I have BDC not FEM. I tried to modify the settings from the F30 sheet in expert mode> MAPPING_NEBELSCHW_R_PART_OF > Didn't do anything at all.

Last edited by Neworgri; 05-28-2019 at 07:21 AM..
Appreciate 0
      07-17-2019, 09:40 PM   #186
kavatski
Private First Class
Canada
34
Rep
106
Posts

Drives: 2019 X1 28iX
Join Date: Jul 2019
Location: Nova Scotia

iTrader: (0)

Quote:
Originally Posted by celo View Post
  • Q3: : For those of you who have coded folding mirrors with Comfort locking, I have a question around timing. If I close my car from the key fob, the mirrors fold instantly, there is no need to long press the close button on the fob. If I try to close the car using Comfort locking, there is a slight delay, i.e. I have to leave my hand over the handle for about 1/2 second more or so to actually fold the mirrors even after setting the delay to 0. If I just tap the handle it closes the car...but the mirrors don't fold, I have to tap and hold for around a 1/2 - 1 second to get the mirrors folding. Are you guys seeing the same behavior?
I have to resurrect this one because mine is the exact same way, and after reading through all the coding threads I can't tell if that's just the way it is, or what. I have the delay set to zero but as above, it only works instantly from the fob. From the door handle I have to hold the ridges for about half a second and then the mirrors fold... but the sunroof cover also starts to close and the windows start to roll up, if open, even though I have the sunroof delay set to 3.5 seconds and the windows to 1.5. So that seems weird.

I've checked and double-checked and all the settings seem right, but I can't get it to fold the mirrors (and nothing else!) with just a touch of the ridges. Can anyone who's done this coding confirm how theirs actually works? If I'm trying to do something that isn't possible it'd be nice to know.
Appreciate 1
      07-20-2019, 07:30 AM   #187
xlr8it
Private
xlr8it's Avatar
Australia
27
Rep
67
Posts

Drives: F48 X1 20d, SLK55AMG
Join Date: Nov 2011
Location: Sydney Australia

iTrader: (0)

Quote:
Originally Posted by kavatski View Post
I have to resurrect this one because mine is the exact same way, and after reading through all the coding threads I can't tell if that's just the way it is, or what. I have the delay set to zero but as above, it only works instantly from the fob. From the door handle I have to hold the ridges for about half a second and then the mirrors fold... but the sunroof cover also starts to close and the windows start to roll up, if open, even though I have the sunroof delay set to 3.5 seconds and the windows to 1.5. So that seems weird.

I've checked and double-checked and all the settings seem right, but I can't get it to fold the mirrors (and nothing else!) with just a touch of the ridges. Can anyone who's done this coding confirm how theirs actually works? If I'm trying to do something that isn't possible it'd be nice to know.
I have coded mine for zero as well and it works just as you described, instant with the fob only
Appreciate 0
      07-20-2019, 11:05 AM   #188
kavatski
Private First Class
Canada
34
Rep
106
Posts

Drives: 2019 X1 28iX
Join Date: Jul 2019
Location: Nova Scotia

iTrader: (0)

Quote:
Originally Posted by xlr8it View Post
I have coded mine for zero as well and it works just as you described, instant with the fob only
Thanks, much appreciated. The description in Bimmercode makes it sound like locking via fob or handle should work the same, but since it doesn't, I wanted to check.
Appreciate 0
      07-20-2019, 02:15 PM   #189
CliveL
Second Lieutenant
United Kingdom
143
Rep
296
Posts

Drives: 2016 X1 F48 xDrive20i xLine
Join Date: Jun 2016
Location: Bournemouth, UK

iTrader: (0)

I'm not sure if it's the same with Bimmercode, but when I set the delay to zero in eSys, I lost the ability to lock the car and disable the interior sensors (pushing the lock button on the fob a second time within a couple of seconds of the first press). I need this for the odd occasion when we leave the dogs in the car to run to the shops or whatever. This might be worth checking if it's a feature you use, otherwise you might not know until your alarm goes off when you think the interior movement sensors are disabled, and they're not...
Appreciate 0
      07-22-2019, 11:58 AM   #190
kavatski
Private First Class
Canada
34
Rep
106
Posts

Drives: 2019 X1 28iX
Join Date: Jul 2019
Location: Nova Scotia

iTrader: (0)

Thanks for pointing that out. Disabling the interior sensors isn't something I'll likely need to do, but it never hurts to be aware of unexpected side effects of coding changes!
Appreciate 0
      07-23-2019, 03:25 PM   #191
halcyon026
Private First Class
United_States
4
Rep
119
Posts

Drives: 2011 E70 35i
Join Date: Apr 2013
Location: United States

iTrader: (0)

Does anyone know if it's possible to get enable a gear indicator? I'm using Carly to code and there are options to enable it, but even with it enabled nothing shows.
It doesn't even seem like the cluster has a space to display the gear. Not even D, N, R.
Appreciate 0
      07-24-2019, 12:48 AM   #192
xlr8it
Private
xlr8it's Avatar
Australia
27
Rep
67
Posts

Drives: F48 X1 20d, SLK55AMG
Join Date: Nov 2011
Location: Sydney Australia

iTrader: (0)

Quote:
Originally Posted by halcyon026 View Post
Does anyone know if it's possible to get enable a gear indicator? I'm using Carly to code and there are options to enable it, but even with it enabled nothing shows.
It doesn't even seem like the cluster has a space to display the gear. Not even D, N, R.
Mine shows the gear in the tacho section
Attached Images
 
Appreciate 0
      08-04-2019, 04:12 PM   #193
pandauk
Private First Class
20
Rep
108
Posts

Drives: BMW X1
Join Date: Sep 2018
Location: UK

iTrader: (0)

Mine does also - though it is the newer black instrument panel.
Appreciate 0
      08-04-2019, 07:56 PM   #194
ejw2011
Second Lieutenant
ejw2011's Avatar
53
Rep
225
Posts

Drives: x3 F25 35i, x1 F48 28i
Join Date: Aug 2011
Location: East coast

iTrader: (1)

Quote:
Originally Posted by halcyon026 View Post
Does anyone know if it's possible to get enable a gear indicator? I'm using Carly to code and there are options to enable it, but even with it enabled nothing shows.
It doesn't even seem like the cluster has a space to display the gear. Not even D, N, R.
I too do not have the gear indication on dash either.
Not sure if it's MY, country specific, car options, ...?
Appreciate 0
      08-12-2019, 11:31 AM   #195
ccIndianRider
New Member
ccIndianRider's Avatar
France
3
Rep
7
Posts

Drives: X1 F48 xDrive 20i xLine 2018
Join Date: Aug 2018
Location: North of France

iTrader: (0)

I think there is a gear indicator only when you use the sport position with manual operating (automatic gear lever on the left position)...
__________________
BMW X1 F48 xDrive 20i xLine 06/2018
Indian Motorcycle Chief Vintage 03/2014
Appreciate 0
      08-12-2019, 11:43 AM   #196
ccIndianRider
New Member
ccIndianRider's Avatar
France
3
Rep
7
Posts

Drives: X1 F48 xDrive 20i xLine 2018
Join Date: Aug 2018
Location: North of France

iTrader: (0)

Since about 3 weeks, I have 5 instead of 3 flashes on the turn indicators without doing anything new.

I don't understand why, because I did a coding change for that in september of 2018 that done no change (always 3 flashes).

I'm using my car since 2018/06/30 and there was only 3 flashes for a year and one day there was 5 flashes...

I don't understand why or how the change came, but I'm very happy with this !
__________________
BMW X1 F48 xDrive 20i xLine 06/2018
Indian Motorcycle Chief Vintage 03/2014
Appreciate 0
      08-12-2019, 04:24 PM   #197
ejw2011
Second Lieutenant
ejw2011's Avatar
53
Rep
225
Posts

Drives: x3 F25 35i, x1 F48 28i
Join Date: Aug 2011
Location: East coast

iTrader: (1)

Quote:
Originally Posted by ccIndianRider View Post
I think there is a gear indicator only when you use the sport position with manual operating (automatic gear lever on the left position)...
Even in sport manual shifting there is no gear indication. It shows no gear change indicator in either m/s or normal gear shifts.
Bringing to dealer to diagnose.
Appreciate 0
      08-12-2019, 05:08 PM   #198
Skyline2.0
Private First Class
41
Rep
127
Posts

Drives: 2018 BMW X1 xDrive
Join Date: Sep 2018
Location: United States

iTrader: (0)

Quote:
Originally Posted by ccIndianRider View Post
Since about 3 weeks, I have 5 instead of 3 flashes on the turn indicators without doing anything new.

I don't understand why, because I did a coding change for that in september of 2018 that done no change (always 3 flashes).

I'm using my car since 2018/06/30 and there was only 3 flashes for a year and one day there was 5 flashes...

I don't understand why or how the change came, but I'm very happy with this !
I noticed this same exact change about 2 months ago and had the same coding difficulties back then. I suspect BMW did an over the air update to add this option as part of the car's stock functionality.

No complaints here either!
Appreciate 1
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 10:23 PM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST