BMW
X1 / X2
BMW Garage BMW Meets Register Search Today's Posts Mark Forums Read
BMW X1 (F48) and X2 (F39) Forums General BMW X2 Forum (F39) Bluetooth problem?

Post Reply
 
Thread Tools Search this Thread
      05-07-2019, 12:50 PM   #1
rice_rocket88
First Lieutenant
37
Rep
320
Posts

Drives: E60 F48 F49
Join Date: Mar 2019
Location: Boston

iTrader: (0)

Bluetooth problem?

I just picked up the car and started driving it in to work now.. and I have a bluetooth problem that seems kind of odd.

So when I "connect" the bluetooth as media to stream music from my phone I have the following issues:
1) it starts , but doesn't actually play. I have to open the player app and then it'll start going and open up the file name. However it still says "please wait" like it's trying to get more information.

2) My phone will not work.. ever.. until I turn off the car and shut off all bluetooth streaming.

When I try to disconnect or do a function it says please wait, still performing bluetooth function or something like that.

Anyone have this issue? On my own e60 it's fine.. on the wife's X1 it's fine (except for problem 1). But it knocks out the car completely which is odd. There are no other permissions that are not checked "on" on my phone side (there's not much to do on the car side).
Appreciate 0
      05-07-2019, 03:10 PM   #2
rounderman
Private
United_States
12
Rep
74
Posts

Drives: 2019 X2 M35
Join Date: Mar 2019
Location: Western NY

iTrader: (0)

Garage List
2019 BMW X2 M35  [0.00]
What kind of phone? I haven't had any basic problems with my Android (other than the lack of support for Android Auto but that is a different issue). I also don't stream much short commute, satellite radio. Is this a car play issue
Appreciate 0
      05-07-2019, 03:18 PM   #3
rice_rocket88
First Lieutenant
37
Rep
320
Posts

Drives: E60 F48 F49
Join Date: Mar 2019
Location: Boston

iTrader: (0)

I'm using a OnePlus 6t now. I could try my alternate work phone which is a Samsung s8.. But in lieu of no problems in the wife's car. Her idrive is one version behind though.
Appreciate 0
      05-07-2019, 03:29 PM   #4
RogerNJ
Private
23
Rep
61
Posts

Drives: 2018 X2
Join Date: Mar 2014
Location: New Jersey

iTrader: (0)

I have a Samsung S10e that just refuses to connect via Bluetooth. I keep getting some ridiculous error "unable to pair, check settings on device". I called Samsung and they said it was a known issue.

Thanks for bringing up this thread because I just noticed a software update on my phone! I'm going to do an update this evening and see what happens.

Interesting that it's an Android device also having problems. I haven't heard/read about any iPhones having the connection issue.....
Appreciate 0
      05-07-2019, 03:30 PM   #5
RogerNJ
Private
23
Rep
61
Posts

Drives: 2018 X2
Join Date: Mar 2014
Location: New Jersey

iTrader: (0)

I have a Samsung S10e that just refuses to connect via Bluetooth. I keep getting some ridiculous error "unable to pair, check settings on device". I called Samsung and they said it was a known issue.

Thanks for bringing up this thread because I just noticed a software update on my phone! I'm going to do an update this evening and see what happens.

Interesting that it's an Android device also having problems. I haven't heard/read about any iPhones having the connection issue.....
Appreciate 0
      05-07-2019, 04:48 PM   #6
dianebrat
Second Lieutenant
United_States
37
Rep
216
Posts

Drives: 2019 orange x2 xDrive28i
Join Date: Dec 2018
Location: Boston'ish

iTrader: (0)

iphone Xs and it has never not paired, in fact I have it and my work 6s both connect rock solid.
Appreciate 0
      05-07-2019, 06:12 PM   #7
rice_rocket88
First Lieutenant
37
Rep
320
Posts

Drives: E60 F48 F49
Join Date: Mar 2019
Location: Boston

iTrader: (0)

It's not that it won't connect.. It's that after I initiate the media playing through Bluetooth I lose the phone function of Bluetooth completely
Appreciate 0
      05-08-2019, 06:40 AM   #8
dianebrat
Second Lieutenant
United_States
37
Rep
216
Posts

Drives: 2019 orange x2 xDrive28i
Join Date: Dec 2018
Location: Boston'ish

iTrader: (0)

Quote:
Originally Posted by rice_rocket88 View Post
It's not that it won't connect.. It's that after I initiate the media playing through Bluetooth I lose the phone function of Bluetooth completely
So I'll add "connects rock solid and stays connected" I have never had a single BT issue in using BT with my phone connected to my car.
Appreciate 0
      05-09-2019, 06:54 AM   #9
rounderman
Private
United_States
12
Rep
74
Posts

Drives: 2019 X2 M35
Join Date: Mar 2019
Location: Western NY

iTrader: (0)

Garage List
2019 BMW X2 M35  [0.00]
I tested my phone last night. S9 latest software from Verizon (in the Android world that sometimes matters). Made a call, streamed some music, made another call while streaming, everything seems to work fine.
Appreciate 0
      05-09-2019, 10:09 AM   #10
rice_rocket88
First Lieutenant
37
Rep
320
Posts

Drives: E60 F48 F49
Join Date: Mar 2019
Location: Boston

iTrader: (0)

Well nuts, the s8 works fine on the car. I did read some people said if there was too much media it might be an issue... I'll try taking off some files on my OnePlus to see if it helps.
Appreciate 0
      05-09-2019, 02:15 PM   #11
rounderman
Private
United_States
12
Rep
74
Posts

Drives: 2019 X2 M35
Join Date: Mar 2019
Location: Western NY

iTrader: (0)

Garage List
2019 BMW X2 M35  [0.00]
Just to add to this. I just was visiting my SA (I couldn't get Home Link to work and he solved it with a trip to my house). He mentioned that if the phone is plugged into a USB port (I use the USB-C in the center console) it might not recognize your phone via Bluetooth for music. Of course I am not sure that specific port is designed for anything beyond charging (more homework). Any way good luck and I will be popping up on the coding thread as soon as I order my adapter,. I repurposed my wife's old iPhone 5s and will use it as my coding device. In doing research it looks like the IOS version works better than Android
Appreciate 0
      05-09-2019, 02:59 PM   #12
rice_rocket88
First Lieutenant
37
Rep
320
Posts

Drives: E60 F48 F49
Join Date: Mar 2019
Location: Boston

iTrader: (0)

Hmm interesting..I thought the same with the USB but still have the problem. I haven't ordered USB c to charge since I have a lot of quick charge cigarette plugs which work pretty darned well. Just remember for coding with Apple you need a wifi adapter.. It will not work via Bluetooth. Coding was a snap though.

Last edited by rice_rocket88; 05-09-2019 at 03:15 PM..
Appreciate 0
      05-09-2019, 03:12 PM   #13
billnchristy
Lieutenant
191
Rep
507
Posts

Drives: 2019 X2 m35i
Join Date: Feb 2019
Location: Atlanta

iTrader: (0)

Garage List
I coded with Bluetooth.

The usb-c has 2.1a capability and charges much faster than the 1a in the front.
Appreciate 0
      05-09-2019, 03:19 PM   #14
rice_rocket88
First Lieutenant
37
Rep
320
Posts

Drives: E60 F48 F49
Join Date: Mar 2019
Location: Boston

iTrader: (0)

Oops, guess I might be thinking of other things like protools or Carly adapters and apple. My quick charge 3.0 cigarette adapters I think are the fastest possible charging for the phone. I've broken down and put all my music on a short profile usb stick for now.
Appreciate 0
      09-28-2019, 05:49 AM   #15
DAC17
Long time BMW fan
United_States
25
Rep
167
Posts

Drives: 2020 X3Mc
Join Date: Oct 2010
Location: CT

iTrader: (0)

Am I correct in saying that our Androids (in my case Galaxy S9+) do not allow text message recognition/reading through our cars' infotainment? I'm at a loss for how to figure this out. And, with no Android Auto, I can't do a workaround.
__________________
2020 BMW X3 30i x-drive (wife's car)
2020 Chevy Bolt LT
2020 BMW X3Mc (to use all the gas the Bolt saves!)
Appreciate 0
      09-28-2019, 10:50 AM   #16
xcelir8bmw
Private First Class
28
Rep
196
Posts

Drives: 2019 BMW X2 M35i
Join Date: May 2019
Location: Chicagoland

iTrader: (0)

Bimmercode fixes this.
Appreciate 0
      09-28-2019, 01:06 PM   #17
rounderman
Private
United_States
12
Rep
74
Posts

Drives: 2019 X2 M35
Join Date: Mar 2019
Location: Western NY

iTrader: (0)

Garage List
2019 BMW X2 M35  [0.00]
text with Android

I tried bimmercode, couldn't get it to work, how what setting? this would be huge for me if it works for you.

thanks for any help
Appreciate 0
      09-30-2019, 12:08 PM   #18
skr9
Private
United_States
9
Rep
86
Posts

Drives: 2020 X2 M35i, 2001 Audi TT
Join Date: Apr 2019
Location: Boston, MA

iTrader: (0)

I am using wireless CarPlay and have found it to be slightly buggy. I had an iPhone X running the latest iOS, and I lost my connection probably about a half dozen times; sometimes CarPlay just doesnt run from start-up, and other times, it would suddenly drop off mid-drive, and when I would go back to select Apple CarPlay, it would say "Function currently not available".
I just got the new iPhone 11 Pro, and it took me two attempts to pair the phone successfully, and yesterday it dropped off mid-drive on me; when I got to a red light, I shut the car off and started back up, and CarPlay launched right away. Does not seem to matter whether or not the phone is in my wireless charger, and I am unable to reliably repeat the error.
Maybe there is a reason no other car maker is offering wireless CarPlay; I certainly will not be happy having to pay for this next year if it is not fixed by BMW.
Appreciate 0
      10-09-2019, 08:12 PM   #19
toddbike
New Member
2
Rep
6
Posts

Drives: BMW X2
Join Date: Jan 2019
Location: Cincinnati, Ohio

iTrader: (0)

iPhone 11s are dropping Bluetooth connections

If you look over on the Apple forums you will see that the new iPhone 11s are having major Bluetooth connection problems. I experienced it first hand with a new 11. I took the phone back and went with a Xr and have had no issues since.
Appreciate 0
      10-10-2019, 08:14 PM   #20
c-m
Private First Class
28
Rep
125
Posts

Drives: N/A
Join Date: Aug 2017
Location: Memphis, TN

iTrader: (0)

I had issues connecting my iPhone X to the CarPlay as well. It works now, but I have to turn off Bluetooth and turn it back on constantly.
Appreciate 0
      01-28-2020, 08:30 AM   #21
RoseByrne
Registered
0
Rep
1
Posts

Drives: BMW X3
Join Date: Jan 2020
Location: NEW YORK

iTrader: (0)

am using an iPhone and the following method solves the problem that my Bluetooth is not working.
1. Reset the device.
2. Upgrade or downgrade the iOS system.
Appreciate 0
      01-30-2020, 06:25 PM   #22
satz
Major
Australia
93
Rep
1,009
Posts

Drives: 2019 BMW X3 M40i
Join Date: Dec 2014
Location: Canberra

iTrader: (0)

I thought I'd written this down, but perhaps on another thread.. But anyway I had problems with BT on my X2 since new with my Iphone 5se, but Apple Carplay worked well.

But now I upgraded my Iphone IOS to 13.3 even Carplay connection has become hit n miss. Sometimes it just doesn't connect, other times it connects instantly. Also I don't like the updated Carplay display which includes "Now Playing" for example.
__________________
2019 X3 M40i, Sophisto grey, H/K, pano
Previous: 2019 BMW X2 Msport, Mineral Grey, Adaptive Suspension, H/K
Previous: 2009 335i LCI, Bluewater
Appreciate 0
Post Reply

Bookmarks

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 12:08 PM.




xbimmers
Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
1Addicts.com, BIMMERPOST.com, E90Post.com, F30Post.com, M3Post.com, ZPost.com, 5Post.com, 6Post.com, 7Post.com, XBimmers.com logo and trademark are properties of BIMMERPOST